Global - Issues with Inbound Calls
Incident Report for NtiretyStatus.com
Resolved
The incident is resolved.
Posted Sep 11, 2020 - 14:38 UTC
Investigating
6:20 AM EDT, Friday September 11th, 2020, an issue with our incoming phone lines was identified. We are currently working with our vendor to resolve the event. At this time, you may not be able to contact support via telephone. Chats, Emails, Tickets and Portal Self Service options are all available.
Posted Sep 11, 2020 - 11:51 UTC
This incident affected: Ntirety Services (Phones).