9/15/2020 - External Emails Blocked
Incident Report for NtiretyStatus.com
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 23:42 UTC
Monitoring
At 5:15 PM ET a vendor level fix was implemented and Ntirety observed services returning to a stable state. The vendor is still experiencing some latency at this time, however it appears to be subsiding. We will continue monitoring but this should be considered the last communication on this event.
Posted Sep 15, 2020 - 22:53 UTC
Identified
At 1:40 pm EDT Ntirety was informed that our spam blocking vendor is blocking external traffic to our mailing lists. This effects responses on tickets coming in and direct email to our domains. We have engaged both internal systems teams and our vendor in order to resolve this event. Customers can still access all self-service through the portal, update tickets and access live chat.
Posted Sep 15, 2020 - 21:12 UTC
This incident affected: Ntirety Services (Customer Portal, Website, Ticketing System).