Customer Chat Support Functionality
Incident Report for NtiretyStatus.com
Resolved
A fix has been implemented, and Ntirety Support can receive and process customer chat requests.
Posted Sep 13, 2023 - 10:32 UTC
Investigating
We are currently investigating an issue where Ntirety Support teams are unable to receive and process customer chat requests. At this time we request you either call into our support line or submit your ticket via self-service.
Posted Sep 13, 2023 - 02:44 UTC
This incident affected: Ntirety Services (Customer Portal, Ticketing System).