Chat Functionality Issue
Incident Report for NtiretyStatus.com
Resolved
Our ITSM vendor has solved the issue, chats are functional and reaching the technicians.
Posted Mar 14, 2024 - 00:34 UTC
Update
We are continuing to investigate this issue.
Posted Mar 13, 2024 - 23:14 UTC
Investigating
We are currently investigating an issue in which customer chats are not reaching technicians. In case of a critical issue or concern please call into Support.
Posted Mar 13, 2024 - 23:10 UTC
This incident affected: Ntirety Services (Ticketing System).